セキュリティ・暗号化ツール
完全クライアントサイド実行のJWT解析、ハッシュ生成、暗号化スイート、クレデンシャル監査。外部送信一切なし。
他のカテゴリを見る:
SPF、DKIM、DMARC、MX、BIMIなど主要なメール認証DNSレコードを一括自動生成。なりすましや迷惑メール判定を防止し、BINDゾーンファイルの書き出しや到達率100%の最適化を支援します。
JWTトークンをブラウザ上で安全にデコード・検証。ヘッダーやクレームの解析、HS256・RS256・ES256の暗号署名検証、有効期限チェックを完全ローカルで実行します。
堅牢なContent Security Policy(CSP)ヘッダーを即座に自動生成。script-src、style-src、nonce、ハッシュ値を設定し、XSS攻撃の防止とCSPエラーの解消を支援します。
JWT(RFC 7519)をブラウザ内で安全にデコード・解析。ヘッダー、ペイロード、有効期限カウントダウン、HMAC署名検証をサーバー送信ゼロで完全ローカル実行。
暗号論的擬似乱数生成器(Web Crypto CSPRNG)を用いた高エントロピーパスワード、覚えられるDicewareパスフレーズ、PIN、APIトークンをブラウザ内で瞬時に安全生成。NIST SP 800-63B準拠。
SHA-256、SHA-512、MD5、SHA-1、SHA-3、Keccak、CRC32をブラウザ内で瞬時に一括算出。Web Crypto APIによる100%クライアントサイド完結。
HMAC (HS256/384/512) および RSA (RS256/384/512) 署名のデコード・構造検査・検証をブラウザ内メモリで100%完結。外部サーバー送信一切なし。
情報エントロピー計算とzxcvbnアルゴリズムにより、総当たり(ブルートフォース)攻撃耐性や解読所要時間を完全ローカルで精密診断します。
Web Crypto APIによるブラウザ内ハードウェア高速化AES-256認証暗号。サーバー送信一切なし、完全ローカル実行。
PEM形式のX.509デジタル証明書をブラウザ内で安全に解析。コモンネーム(CN)、SAN(別名)、発行機関(CA)、SHA-256指紋、有効期限を可視化します。
暗号通貨(ビットコイン、ソラナ)やIPFSで標準採用されるBase58およびBase58Checkのエンコード・デコードツール。誤読防止アルファベットとSHA-256チェックサム検証に対応。
ソルトラウンド数 (4〜16) を自由に設定できるEksblowfish暗号ベースのBcryptハッシュ生成&ローカル検証ツール。完全ブラウザ完結。
RFC 2104 準拠の鍵付きハッシュ(HMAC-SHA256、HMAC-SHA512、HMAC-SHA1、HMAC-MD5)をブラウザ内で瞬時に算出・定数時間(Timing-Safe)検証。
Web Crypto APIを利用して、ブラウザ内で安全に2048/4096ビットのRSA暗号化キーペア(PEM形式)を生成・ダウンロードできます。
最新のTLS暗号化ハンドシェイク、ECDHE鍵交換、ALPNネゴシエーション、AES-GCMおよびChaCha20暗号スイートのセキュリティ強度をシミュレート・分析します。
Curve25519 秘密鍵・公開鍵ペア、事前共有鍵 (PSK)、および完全な wg0.conf トンネル設定をブラウザ内で安全に生成。サーバー送信ゼロ、ローカル暗号処理、スマホ用QRコード出力に対応します。
CA証明書、クライアント証明書、秘密鍵、TLS-Auth / TLS-Crypt 署名を1つの .ovpn ファイルに完全インライン統合。iOS、Android、macOS、Linux で即座に読み込めるプロファイルをブラウザ内で安全に作成します。
WebサイトのHTTPレスポンスヘッダーを検査し、Content-Security-Policy (CSP)、HSTS、X-Frame-Options、Permissions-Policyの導入状況と安全性を診断します。
JSON Web Key(JWK / JWKS)とPEM(PKCS#1 / PKCS#8 / SPKI)形式の相互変換を完全ブラウザ内完結で実行。Auth0やCognitoの鍵解析に対応。
HS256/RS256署名、カスタムクレーム、有効期限設定を備えたテスト用JSON Web Token(JWT)をブラウザ内で安全に生成します。
SHA-256、SHA-384、SHA-512のBase64ハッシュをブラウザ内で直接計算し、CDN配信用の安全なHTMLタグを自動生成します。
ブラウザローカル環境でRSA、ECDSA、Ed25519のPEM秘密鍵・公開鍵(PKCS#1, PKCS#8, SPKI)を安全にパースし、鍵長・暗号アルゴリズム・指紋を解析します。
RFC 6238準拠のTOTP動的ワンタイムパスワードをブラウザ上で計算。Base32秘密鍵の検証、カウントダウンタイマー、otpauth:// URIの生成に対応。
JWTトークンの署名をブラウザローカルで辞書照合し、既知の脆弱な共通鍵(弱パスワード)が使用されていないか安全に監査・診断します。
OpenSSH公開鍵(RSA、Ed25519、ECDSA)をローカル解析し、SHA-256・MD5フィンガープリントおよびOpenSSH特有のASCII Randomartを即座に描画します。
日本語や多言語国際化ドメイン(IDN)とASCII Punycode(xn--)を双方向変換。キリル文字・ギリシャ文字などの同形異義語(ホモグラフ攻撃)やフィッシングのリスクを解析します。
未加工のHTTPリクエスト/レスポンスヘッダーをパースし構造化テーブルに分解。Cache-Controlディレクティブの診断、セキュリティヘッダー評価、Set-Cookieの属性解析に対応。
EFF公式Diceware単語リストと暗号学的乱数(CSPRNG)を用い、記憶しやすく高強度なマルチワードパスフレーズを瞬時に生成。シャノン情報エントロピーとオフライン解読耐性をリアルタイム算出します。
RFC 7519 登録済みクレームおよびカスタムクレームを設計し、exp、nbf、iat、jti、aud のタイムスタンプを即座に計算・検証する開発者ツール。
WireGuard Curve25519 公開鍵・秘密鍵ペア、事前共有鍵 (PSK)、クライアントおよびサーバー設定ブロックを生成します。
Bcrypt、Apache MD5 (APR1)、SHA-1ハッシュ方式による安全なHTTP Basic認証用パスワードおよび.htpasswdファイルをブラウザ上で生成します。
RFC 7517 JSON Web Key (JWK / JWKS) を PKCS#8 / SPKI PEM 形式に変換し、公開鍵・秘密鍵 PEM を JWK 構造に相互変換します。
カメラ、マイク、位置情報、決済などの最新Permissions-Policy HTTPレスポンスヘッダーを厳格なオリジン許可リストで構築・検証・テストします。
max-age 計算機、includeSubDomains、および Chrome プリロード適合性チェックを備えた HSTS ヘッダーを生成します。
ルートログイン無効化、公開鍵認証の強制、安全な暗号スイートの指定、アイドルタイムアウトの設定を備えた本番向け sshd_config を生成します。
Ubuntu UFW のファイアウォール規則、デフォルト遮断ポリシー、レート制限、ポート転送、自動実行可能な Bash スクリプトをブラウザ上で安全に生成します。
INPUT、FORWARD、OUTPUTチェインのルール構築、ステートフル検査、SYNフラッド対策、NATポートフォワーディング、本番用シェルスクリプト出力を備えたLinux iptablesジェネレーター。
IPv4/IPv6 CIDR、MX、A、includeメカニズムおよびSoftFail/HardFailポリシーを含むRFC 7208準拠のDNS SPFレコードを構築・検証・最適化します。
ポリシー適用(none/quarantine/reject)、rua/ruf集約レポート、アライメントタグを備えたRFC 7489準拠のDMARC DNS TXTレコードを生成します。
RFC 8659に準拠した認証局認可(CAA)DNSレコードを生成し、SSL/TLS証明書の発行制限、ワイルドカードポリシー、不正発行インシデント通知(iodef)を設定します。
RFC 6376準拠のDNS DKIM TXTレコード(v=DKIM1; k=rsa; p=...)の構築、セレクタ命名規則、255文字制限の分割手法、および認証検証手順を解説します。
RFC 8461 MTA-STSポリシーファイルおよび_mta-sts/_smtp._tls DNS TXTレコードをブラウザ上で即座に生成します。